# Microsoft Excel Tips & Tricks

*For the Guru in You*

## Sum of Viewers

<table>
<thead>
<tr>
<th>Program</th>
<th>East</th>
<th>North</th>
<th>South</th>
<th>West</th>
<th>Grand Total</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bat Man</td>
<td>102</td>
<td>91</td>
<td>87</td>
<td>99</td>
<td>379</td>
</tr>
<tr>
<td>Ben Ten</td>
<td>107</td>
<td>133</td>
<td>125</td>
<td>140</td>
<td>505</td>
</tr>
<tr>
<td>Bob The Builder</td>
<td>91</td>
<td>73</td>
<td>85</td>
<td>79</td>
<td>328</td>
</tr>
<tr>
<td>Mr Maker</td>
<td>49</td>
<td>50</td>
<td>59</td>
<td>51</td>
<td>209</td>
</tr>
<tr>
<td>Night Garden</td>
<td>57</td>
<td>44</td>
<td>37</td>
<td>32</td>
<td>170</td>
</tr>
<tr>
<td>Spider Man</td>
<td>206</td>
<td>138</td>
<td>172</td>
<td>240</td>
<td>756</td>
</tr>
<tr>
<td>Wiggles</td>
<td>72</td>
<td>86</td>
<td>83</td>
<td>95</td>
<td>336</td>
</tr>
<tr>
<td><strong>Grand Total</strong></td>
<td>684</td>
<td>615</td>
<td>648</td>
<td>736</td>
<td>2683</td>
</tr>
</tbody>
</table>

By Mynda Treacy  
My Online Training Hub  
Excel Tips & Tricks

Dear fellow Excel enthusiast,

Ok, if you’re not an enthusiast yet, I hope that with the help in these Tips & Tricks you soon will be.

These are some of my favourite tips and power features that’ll get you well on your way to ‘Excel Guru Status' giving you not only the recognition you deserve, but also making your work more enjoyable.

Kind regards,

Mynda Treacy
Co-founder
My Online Training Hub

Share the knowledge!

You have permission to share this e-book via email, printed or even post it on your website, Facebook account, Twitter or LinkedIn.

The only conditions are:

1. You don’t charge anyone money for it. That’s my right.
2. You don’t change, edit, or alter the digital format or contents.
3. All links must remain in place.

My hope for this e-book is that you please share it with as many people as possible, and by sharing the knowledge many more people will love Excel and love their work.

You can find more Microsoft Office training (including Excel, Word and Outlook video tutorials) and resources at http://www.MyOnlineTrainingHub.com

Questions – If you have any questions or feedback please contact me at:
http://www.myonlinetraininghub.com/contact-us or mynda.treacy@myonlinetraininghub.com

© Copyright 2016 MyOnlineTrainingHub.com
Contents

Keyboard Shortcuts ................................................................................................................................................. 4
Tips & Tricks............................................................................................................................................................... 6
  Move, insert and copy columns, rows and cells using the Mouse + SHIFT or CTRL.............................................. 8
  Want to tamper-proof your workbook? .................................................................................................................. 9
Must Know Formulas .............................................................................................................................................. 14
Power Formulas ....................................................................................................................................................... 16
Cool Tools ................................................................................................................................................................ 17

Tip: Click menu to jump to section
Keyboard Shortcuts

1. **ALT+=** Inserts a SUM formula.

2. **CTRL+TAB** Switches between open Excel windows.

3. **CTRL+A** – this has various scenarios:
   a. If you are in regular data range and press CTRL+A all the data is selected.
   b. If you press CTRL+A a second time in the same range selects the entire spreadsheet.
   c. If you are in a table then pressing the CTRL+A key selects the data excluding the total row AND titles.
   d. If you press the CTRL+A key a second time it selects the data, titles, and total row.
   e. It does not make any difference whether the spreadsheet contains data or not, if you are outside the data area, in a blank area with no directly adjacent cells containing data, CTRL+A selects the entire sheet.
   f. If you have one or more objects e.g. Charts, selected then pressing CTRL+A selects them all.

4. **CTRL+1** Displays the Format Cells dialog box.

5. **CTRL+SHIFT+"** Copies the value from the cell above the active cell into the cell or the Formula Bar.

6. **F4** Repeats an action, or if you’re editing a cell and the cursor is in between the cell references it will insert the $ signs for absolute references. Repeated pressing F4 will scroll through different levels of absolute references.

7. **CTRL+Z** Uses the **Undo** command to reverse the last command or to delete the last entry that you typed.

8. **CTRL+’** Copies a formula from the cell above the active cell into the cell or the Formula Bar.

9. **CTRL+K** Opens the Hyperlink dialog box.

10. **CTRL+F** Opens the Find dialog box.

11. **CTRL+H** Opens the Find & Replace dialog box.

12. **CTRL+N** Opens a new workbook.

13. **CTRL+O** Displays the **Open** dialog box to open or find a file. Note: In Excel 2013 it opens the File tab of the ribbon.
14. **F2** Edits the active cell and positions the insertion point at the end of the cell contents. It also moves the insertion point into the Formula Bar when editing in a cell is turned off.

15. **F7** Runs Spell Check on the entire worksheet if only one cell is selected, otherwise Spell Checks the selected range. You can also spell check multiple sheets by grouping them first.

16. **CTRL+SHIFT+F3** Inserts named ranges for an entire table automatically based on the column or row headings (your choice).

17. **CTRL+P** Opens Print dialog box.

18. **CTRL+S** Saves workbook.

19. **CTRL+C** Copy

20. **CTRL+X** Cut

21. **CTRL+V** Paste

22. **END** key then Up or Down, or Left or Right Arrows OR the **CTRL+Up Arrow/Down Arrow** etc. Move to end of a range of cells (column or row). Your selected cell will stop at any empty cell in the range, or if cells are empty it will stop at the next populated cell in the column or row.

23. **CTRL+HOME** Quickly move to home. If you have frozen panes your cursor will stop at the intersection of the frozen panes.

24. **CTRL+Page Up** or **CTRL+Page Down** Scroll between worksheets

25. **CTRL+`** View formulas instead of values (note the ` shares the tilde ~ key)

26. **CTRL+D** copies the cell above. Select a range or row and then CTRL+D to copy the row.
Tips & Tricks

27. **Transpose Data** – Copy data > Paste Special > Transpose

28. **Increase Numbers by Set Amount** – Enter the figure you want to increase numbers by, say 10%, you’d enter 1.1. Copy the cell containing 1.1 > highlight the cells containing the numbers you want to increase > Paste Special > Multiply. Bonus tip: convert negative values to positive by multiplying by -1 and vice versa.

29. **AutoFill a Series or Formulas** – Double Click on the + symbol on the bottom right of a cell that is adjacent to the range you want to fill.

30. **Force a carriage return in a cell instead of wrapping the text** – ALT+ENTER while editing the cell.

31. **Use Format Painter more than once** – Double Click the Format Painter and use it as many times as you like. When you’re done press ESC. Only applies in Excel 2007 and higher.

32. **Format Sheet Tab Colours** – Right-Click mouse on Sheet Tab > Tab Colour.
33. **Combine Text from Multiple Cells** – Enter your formula with the ampersand ‘&’ between the cell references e.g. =A1&A2&A3 will add the text in cell A1, A2 and A3 together. Note: if you want to add a space between the text from each cell enter your formula like this: =A1&” “&A2&” “&A3 Where the “ ” is adding a space.

34. **Delete blank cells in a row or column** – Highlight the column or row containing cells you want to delete. Press CTRL+G to open the Go To Dialog Box > Special > Blanks. Delete cells, rows or columns.

35. **Fill blank cells in a row or column** - Highlight the column or row containing cells you want to fill. Press CTRL+G to open the Go To Dialog Box > Special > Blanks. Enter the text or formula you want to insert > press CTRL+ENTER to enter the text/formula in every blank cell.

36. **Copy & Paste visible cells only** – In a filtered list of data copy the list > Paste Special > Skip Blanks. Or if your list isn’t filtered use Go To Special to select visible cells only: CTRL+G > Special > Visible Cells Only > Paste. Or shortcut key ALT+;

37. **Insert custom cell formats**

<table>
<thead>
<tr>
<th>Custom Cell Formats</th>
<th>Text Before Formatting</th>
<th>Custom Format</th>
<th>Formatted Text</th>
</tr>
</thead>
<tbody>
<tr>
<td>Brackets for negative values</td>
<td>-500</td>
<td>#,##0;(#,##0)</td>
<td>(500)</td>
</tr>
<tr>
<td>Red and brackets for negative values</td>
<td>-500</td>
<td>#,##0.00;<a href="#,##0.00">Red</a></td>
<td>(500.00)</td>
</tr>
<tr>
<td>Day of the week in full</td>
<td>27/03/2010</td>
<td>dddd</td>
<td>Saturday</td>
</tr>
<tr>
<td>Day, date, month and year</td>
<td>27/03/2010</td>
<td>ddd dd mmm yyyy</td>
<td>Sat 27 Mar 2010</td>
</tr>
<tr>
<td>Month</td>
<td>27/03/2010</td>
<td>mmmm</td>
<td>March</td>
</tr>
<tr>
<td>Phone Numbers</td>
<td>755551234</td>
<td>00 0000 0000</td>
<td>07 5555 1234</td>
</tr>
<tr>
<td>Phone Numbers with Brackets</td>
<td>755551234</td>
<td>(00) 0000 0000</td>
<td>(07) 5555 1234</td>
</tr>
<tr>
<td>Fractions</td>
<td>10.5</td>
<td># ??/??</td>
<td>10 1/2</td>
</tr>
</tbody>
</table>

For more custom cell formats click the link below:

http://www.myonlinetraininghub.com/excel-custom-cell-formats
38. Use **Named Ranges** in your formulas to make them easier to build and read when you come back to your workbook weeks or months later.  

39. **Apply different formats within one cell** – could be different fonts, font colours, styles etc. Select the cell you want to format > F2 to edit the cell > highlight the text you want to change > For Excel 2007+ use the formatting tools on the Home tab of the ribbon or for Excel 2003 use the formatting icons on the toolbar.

**Move, insert and copy columns, rows and cells using the Mouse + SHIFT or CTRL.**

40. **Move column, row or cells:** Select the range of cells, column(s) or row(s) > hover your mouse over the edge of your selected range of cells (or columns or rows) > when the mouse pointer changes to a 4 pointed arrow left click the mouse and hold down while you drag your cells to a new location.

41. **Move and insert column, row or cells:** As above except also hold down the SHIFT key while hovering your mouse over the edge of the selected area. Then drag the cells (while holding down the SHIFT key) and insert them in a new location.

42. **Copy and paste a column, row or cells:** As above except hold down the CTRL key while hovering your mouse over the edge of the selected area. Then drag the cells (while holding down the CTRL key) and release the mouse where you want to paste the data.

43. **Copy and insert a column, row or cells:** As above except hold down the CTRL+SHIFT keys while hovering your mouse over the edge of the selected area. Then drag the cells (while holding down the CTRL+SHIFT keys) and release the mouse where you want to insert your data.

**Mouse Pointer in 40 and 41**

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Number</td>
<td>Day</td>
</tr>
<tr>
<td>2</td>
<td>1</td>
<td>Monday</td>
</tr>
<tr>
<td>3</td>
<td>2</td>
<td>Tuesday</td>
</tr>
<tr>
<td>4</td>
<td>3</td>
<td>Wednesday</td>
</tr>
<tr>
<td>5</td>
<td>4</td>
<td>Thursday</td>
</tr>
<tr>
<td>6</td>
<td></td>
<td></td>
</tr>
<tr>
<td>7</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Mouse Pointer in 42 and 43**

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Number</td>
<td>Day</td>
</tr>
<tr>
<td>2</td>
<td>1</td>
<td>Monday</td>
</tr>
<tr>
<td>3</td>
<td>2</td>
<td>Tuesday</td>
</tr>
<tr>
<td>4</td>
<td>3</td>
<td>Wednesday</td>
</tr>
<tr>
<td>5</td>
<td>4</td>
<td>Thursday</td>
</tr>
<tr>
<td>6</td>
<td></td>
<td></td>
</tr>
<tr>
<td>7</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Note: these mouse pointers may appear different on your PC if you have a different operating system or have customised how your mouse appears. Not to worry, the shortcuts above will still work as described.
44. **Quickly enter links to a range of cells** – Copy cells you want to link to > Paste Special > Paste Links.

45. **Convert formulas to values** - Copy cells containing formulas > Paste Special > Paste Values.

46. **Copy formulas only** - Copy cell containing formula you want to copy > Paste Special > Paste Formulas.

47. **Freeze rows and or columns** at the top or left of your workbook so that headings stay in place while you scroll down the worksheet. Place your cursor at the intersection of the rows/columns you want fixed in place i.e. Frozen then
   For Excel 2003 > Window > Freeze Panes
   For Excel 2007+ > View tab of the ribbon > Freeze Panes

48. **Synchronous Scrolling** – want to compare two workbooks and have them both scroll at the same time? With two workbooks open:
   For Excel 2003 > Window > Compare Side by Side > Synchronous Scrolling
   For Excel 2007+ > View tab of the ribbon > View side by side > Synchronous Scrolling

---

**Want to tamper-proof your workbook?**

49. **Hide worksheet tabs** > Windows Button > Excel Options > Advanced > Display Options > uncheck ‘Show sheet tabs’.

50. **Hide row and column headers** > Windows Button > Excel Options > Advanced > Display Options for this workbook > uncheck ‘Show row and column headers’ or View tab of the ribbon > uncheck ‘Headings’ in the Show/Hide group.

51. **Hide the formula bar** > View tab of the ribbon > uncheck ‘Formula Bar’ in the Show/Hide group.

52. **Add non-contiguous print areas** (Excel 2007+ only) – Set first print area, then select second print area and on the Page Layout tab of the ribbon select ‘Add to print area’. Each print range will print on a separate page.
53. **Pick from a list of existing values** – in the cell under your data hold down ALT + Down Arrow - Excel will give you a list of values to choose from. Use the arrow keys to select the one you want and press ENTER to insert it.

54. **Print titles on each page automatically** – On the Page Layout tab of the ribbon select Print Titles. This will open the Page Setup dialog box. Enter your rows and or columns you want repeated in the boxes highlighted below by clicking in the box and then clicking on the row or column header on your worksheet.

![Page Setup dialog box](image)

55. **Absolute References** – Understanding Absolute References is essential to working with formulas in Excel. *Remember: use the F4 tip in the keyboard shortcuts when working with absolute references.*

http://www.myonlinetraininghub.com/excel-2007-absolute-references-%e2%80%93-the-missing-link
56. **Quickly SUM a range of cells** – select entire table (or it could be just a row or column of values) plus the blank cells you want your SUM formula in, then press the ALT+= keys.

*Before pressing ALT+=*

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
<th>G</th>
<th>H</th>
<th>I</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Jane</td>
<td>54</td>
<td>44</td>
<td>30</td>
<td>26</td>
<td>36</td>
<td>65</td>
<td>61</td>
<td>Total</td>
</tr>
<tr>
<td>3</td>
<td>John</td>
<td>65</td>
<td>26</td>
<td>31</td>
<td>34</td>
<td>39</td>
<td>46</td>
<td>46</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>Jim</td>
<td>28</td>
<td>60</td>
<td>32</td>
<td>42</td>
<td>46</td>
<td>46</td>
<td>46</td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>Jack</td>
<td>57</td>
<td>33</td>
<td>50</td>
<td>30</td>
<td>45</td>
<td>60</td>
<td>56</td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>Total</td>
<td>191</td>
<td>127</td>
<td>165</td>
<td>171</td>
<td>183</td>
<td>205</td>
<td>151</td>
<td>1294</td>
</tr>
</tbody>
</table>

*These are the blank cells where the SUM formula will be.*

*After pressing ALT+=*

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
<th>G</th>
<th>H</th>
<th>I</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Jane</td>
<td>41</td>
<td>49</td>
<td>39</td>
<td>46</td>
<td>25</td>
<td>51</td>
<td>33</td>
<td>264</td>
</tr>
<tr>
<td>3</td>
<td>John</td>
<td>58</td>
<td>57</td>
<td>36</td>
<td>25</td>
<td>47</td>
<td>29</td>
<td>30</td>
<td>282</td>
</tr>
<tr>
<td>4</td>
<td>Jim</td>
<td>27</td>
<td>56</td>
<td>43</td>
<td>46</td>
<td>46</td>
<td>63</td>
<td>50</td>
<td>333</td>
</tr>
<tr>
<td>5</td>
<td>Jack</td>
<td>65</td>
<td>65</td>
<td>48</td>
<td>54</td>
<td>65</td>
<td>62</td>
<td>38</td>
<td>397</td>
</tr>
<tr>
<td>6</td>
<td>Total</td>
<td>191</td>
<td>127</td>
<td>165</td>
<td>171</td>
<td>183</td>
<td>205</td>
<td>151</td>
<td>1294</td>
</tr>
</tbody>
</table>

*Now see formulas that were inserted.*

57. **Generate a unique list of values from a range** – Select the range > Data > Filter > Advanced Filter > Unique Records Only. Note: select if you want to copy it to a new location or replace the existing data by selecting ‘Copy to another location’ and then inserting the ‘Copy to’ cell reference.

58. **Use the AutoCalculate Menu** in the bottom right of your Excel window to get a quick sum, average, or count. Right click on the area to alternate view Min, Max and more. Select the range of cells you want to sum/average/count. Hold down CTRL to select non-contiguous ranges.
59. **You don’t have to start your formulas with** `=` - If you’re a fan of the number keypad and arrow keys then it’s sometimes inconvenient to move your hand across to the `=` symbol every time you want to enter a formula. If you start a formula with `+` or even a `–` for negative values, Excel will put the `=` sign in for you when you press ENTER. After pressing ENTER your formula will look like this `=+A1+A2` which is perfectly fine, or if your want to subtract the value in A1 it will look like this `=-A1+A2`.

60. **Use Text to Columns to separate a column of data containing first names and last names** – Let’s say you have First Names and Last Names separated by a space in column A. Select the cells > Data > Text to Columns > Delimited > Next > Choose Delimiter (space in this example) > Next > Select data format and Destination > Finish

![Image of Text to Columns Wizard](image.png)

61. **Center Across Selection** – Instead of Merging Cells, which puts limits on inserting and deleted columns and rows among other things, simply format the cells alignment to ‘Center across selection’. CTRL+1 to open Format Cells dialog box > Alignment tab > Horizontal Text Alignment set to ‘Center across selection’.
62. **Find the number of days between two dates** – Enter your dates in this formula inside double quotes ="20/6/2011"-"28/10/2006" Result = 1696

Note: It’s best to always enter the dates in cells (without the double quotes) and then use a formula to calculate the days e.g. =B1-A1

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>28/10/2006</td>
<td>20/06/2011</td>
<td></td>
<td>1696</td>
</tr>
</tbody>
</table>

63. **Move quickly to the end of a range of cells** – select a cell in the range > move your mouse to the edge of the cell until your mouse pointer changes to a 4 headed arrow > double click. You can do this on any edge of the cell to move in the direction of your choice.

64. **Fill Handle Cool Tricks** – Most of us know that you can left-click the mouse and drag the fill handle to fill a series (the fill handle is when your mouse pointer changes to a + symbol when hovered over the bottom right of the cell range – see image), but have you tried right-clicking the mouse while you drag the fill handle? There are myriad choices when you do this, so have a go and experiment.
Must Know Formulas

Click the links or copy and paste the URL into your browser to read the full tutorial for each formula.

65. **IF** – Learning how to write an IF statement increases the power and functionality of Excel ten fold.
   http://www.myonlinetraininghub.com/excel-2007-%e2%80%93-if-statement-explained

66. **Nested IF Statements** - for extra credit:

67. **IF, OR and AND** used together – know these and you’re unstoppable!

68. **VLOOKUP Exact Match** – Most people only know one way to do a VLOOKUP, but I’m going to let you in on a secret; there are two ways...actually there are many more than two ways but these are two methods will allow you to do most things you want.
   http://www.myonlinetraininghub.com/excel-2007-%e2%80%93-vlookup-formulas-explained

69. **VLOOKUP Sorted List** – This is the other way to do a VLOOKUP.
   http://www.myonlinetraininghub.com/excel-2007-%e2%80%93-vlookup-sorted-list-explained

70. **HLOOKUP** – the same as VLOOKUP but for horizontal lists.
   http://www.myonlinetraininghub.com/excel-hlookup-formulas-explained

71. **SUMIF and SUMIFS** for Excel 2007+ users – Like the IF statement but for SUM. Excel also has AVERAGEIF and AVERAGEIFS which work the same as the SUM only they Average.

72. **COUNTIF and COUNTIFS** for Excel 2007+ users – similar to SUMIF only since it’s only counting it’s slightly different.

73. **COUNTA** – COUNTIF counts number values, but if you want to count text use COUNTA.

75. **ROUND, ROUNDSP, ROUNDDOWN** – Before long you’ll need to round your numbers with more accuracy than simply formatting the font. [http://www.myonlinetraininghub.com/how-to-round-numbers-in-excel-using-round-formulas](http://www.myonlinetraininghub.com/how-to-round-numbers-in-excel-using-round-formulas)

76. **FV Calculate compound interest on savings** – Want to save some money for a rainy day and curious to know what it’ll be worth? Excel can tell you: [http://www.myonlinetraininghub.com/how-to-calculate-interest-on-savings-in-excel](http://www.myonlinetraininghub.com/how-to-calculate-interest-on-savings-in-excel)

77. **IFERROR** - Once you start using some of the formulas above you’re likely to have errors returned. If you’re expecting errors and want to hide them you can use the IFERROR formula (Excel 2007+ only). [http://www.myonlinetraininghub.com/excel-2007%e2%80%99s-iferror-puts-an-end-to-messy-workarounds](http://www.myonlinetraininghub.com/excel-2007%e2%80%99s-iferror-puts-an-end-to-messy-workarounds)

78. **MIN, MAX, SMALL and LARGE** – These may seem straight forward, but I’ll show you a few tricks that you won’t find in the Excel Help Files. [http://www.myonlinetraininghub.com/excel-min-max-small-and-large-functions](http://www.myonlinetraininghub.com/excel-min-max-small-and-large-functions)

79. **UPPER, LOWER and PROPER** – Fix text that isn’t formatted as you want. Change all CAPITALS to all Lower, or make the first letter in each word a capital (PROPER). [http://www.myonlinetraininghub.com/excel-upper-lower-and-proper-functions](http://www.myonlinetraininghub.com/excel-upper-lower-and-proper-functions)


81. **Time Calculations** – Most people at some stage or another need to calculate time in Excel, but if you don’t understand how Excel treats time you’ll find it infuriating! [http://www.myonlinetraininghub.com/calculating-time-in-excel](http://www.myonlinetraininghub.com/calculating-time-in-excel)

82. **NOW() and TODAY()** – simply type =NOW() in a cell and you will get the date and time as per your computer clock or =TODAY() will give you the date only. Handy for date/time stamping your printed reports.
Power Formulas

83. INDEX and MATCH – With these powerful formulas combined you can get around the limitations of VLOOKUP and look up columns to the left.  
http://www.myonlinetraininghub.com/excel-index-and-match-functions

84. CHOOSE – This function isn’t much use on its own but it’s powerful when you use it with other formulas, like the VLOOKUP.  
http://www.myonlinetraininghub.com/excel-choose-function

85. VLOOKUP with CHOOSE – An alternative to INDEX and MATCH that enables you to get around VLOOKUP not allowing you to lookup columns to the left.  
http://www.myonlinetraininghub.com/excel-vlookup-to-the-left-using-choose

86. OFFSET – Tired of having to update your totals to incorporate new rows? This is one great feature of the OFFSET function, but it has many more uses.  
http://www.myonlinetraininghub.com/excel-offset-function-explained

87. FLOOR and CEILING – If calculating prices is something you do in Excel and you want to round them to end in 99 cents or 97 cents then the FLOOR function is your best friend.  
http://www.myonlinetraininghub.com/excel-ceiling-and-floor-functions

88. RAND and RANDBETWEEN – Generating random data is something I do regularly as I need to create data to support the tutorials I write, but you could also use it in your work to do the same, or team it with CHOOSE and use it to choose random values from a list. Read the tutorial for more examples:  
http://www.myonlinetraininghub.com/excel-rand-and-randbetween-functions

89. SUMPRODUCT – This is a great alternative to SUMIFS, COUNTIFS and AVERAGEIFS for those Excel users still stuck with 2003. If you’re an Excel 2007 or 2010 user SUMPRODUCT is one formula that will take you to the heady heights Excel Guru.  

90. Array Formulas – Similar to SUMPRODUCT, but you can use some of the existing functions in an array formula to increase their capability. These are for people serious about getting the most out of Excel.  
http://www.myonlinetraininghub.com/excel-array-formula
Cool Tools

91. **Shapes and SmartArt** – In Excel 2007+ the sophistication of Shapes and SmartArt can give your workbooks and reports a truly professional finish. Don’t be surprised if people think you got a graphic designer involved. [http://www.myonlinetraininghub.com/microsoft-excel-shapes-smartart](http://www.myonlinetraininghub.com/microsoft-excel-shapes-smartart)

92. **Camera Tool** – You won’t find any mention of the camera tool in a standard Excel course. After all you won’t even find it in the tool bar or ribbon. It’s handy if you only have one monitor and pine for two, or if you want to create dashboards with lots of small charts. [http://www.myonlinetraininghub.com/microsoft-excel-camera-tool](http://www.myonlinetraininghub.com/microsoft-excel-camera-tool)

93. **Conditional Formatting** – In Excel 2007+
Conditional Formatting is substantially improved. Use it to bring life to your drab data, make highlighting duplicates instant and much more. [http://www.myonlinetraininghub.com/how-to-use-excel-2007%E2%80%99s-conditional-formatting](http://www.myonlinetraininghub.com/how-to-use-excel-2007%E2%80%99s-conditional-formatting)

94. **Filters** – If you work with large amounts of data then Filters can give you instant data mining abilities. You can also use them in conjunction with Conditional Formatting. [http://www.myonlinetraininghub.com/how-to-use-filters-in-excel-2007](http://www.myonlinetraininghub.com/how-to-use-filters-in-excel-2007)

95. **Drop Down Lists** – or Data Validation as it’s called in Excel. If you build forms or reports for other’s to use Data Validation can make them more interactive and reduce the chances of the wrong data being filled out. [http://www.myonlinetraininghub.com/excel-drop-down-lists](http://www.myonlinetraininghub.com/excel-drop-down-lists)

96. **Insert Subtotals** – unlike the SUBTOTAL function mentioned earlier, this tool actually identifies changes in your data and inserts subtotals where you want. [http://www.myonlinetraininghub.com/how-to-insert-subtotals-in-excel](http://www.myonlinetraininghub.com/how-to-insert-subtotals-in-excel)

97. **Outlines** – The subtotal tool above inserts outlines automatically for you when it inserts the subtotals, but you can insert outlines yourself using the Group and Ungroup tools. I love using these instead of hiding columns and rows as it allows me to hide and unhide again at the click of only one button.
98. **Importing Data Into Excel** – You can import data from the Web, an Access Database, text or CSV files and more. Once you create the link to the data you’re importing you can update it as frequently as every minute, to every time you open the workbook.

http://www.myonlinetraininghub.com/importing-data-into-excel

99. **Excel Tables** – In Excel 2007 tables are vastly improved. Formatting your data in a Table allows you to add to the content and have any formulas or pivot tables that reference the data automatically pick up the new cells. Plus there’s a range of other benefits like great predefined formatting and more. http://www.myonlinetraininghub.com/excel-2007-tables
100. **PivotTables** – A lot of people are afraid of PivotTables, but they really are quite simple once you understand the basics. If you work with large amounts of data PivotTables can create dynamic reports in seconds from tens of thousands of rows. 

Thank you for taking the time to read these Tips & Tricks. Enjoy using your new Excel powers. Feel free to email me with feedback or ideas.
Kind regards,
Mynda

Share the knowledge!

Now that you’ve read the whole book please forward it to your friends and colleagues and share the knowledge. Please just make sure you follow the conditions below.

You have permission to share this e-book via email, printed or even post it on your website, Facebook account, Twitter or LinkedIn.

The only conditions are:

1. You don’t charge anyone money for it. That’s my right.
2. You don’t change, edit, or alter the digital format or contents.
3. All links must remain in place.

My hope for this e-book is that you please share it with as many people as possible, and by sharing the knowledge many more people will love Excel and love their work.

Did you like these tips & tricks? Want more?

Video Training: You can find more Microsoft Office training, including Excel, Word and Outlook, plus other free software and resources at http://www.MyOnlineTrainingHub.com

Sign up for our free video training and get instant access to over 150 video tutorials on Excel, Word and Outlook.

Excel Newsletter: http://www.myonlinetraininghub.com/sign-up-for-100-excel-tips-and-tricks

Follow My Online Training Hub:

RSS Feed: http://feeds.feedburner.com/MyOnlineTrainingHub/feedme
Facebook: http://www.facebook.com/pages/My-Online-Training-Hub/143694365645900
Twitter: http://twitter.com/onlinetrainingh

Questions — If you have any questions or feedback please contact me at: http://www.myonlinetraininghub.com/contact-us or mynda.treacy@myonlinetraininghub.com

© Copyright 2011 MyOnlineTrainingHub.com